VW Vortex - Volkswagen Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
88 Posts
Discussion Starter · #3 ·
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

My turbo is boosting sparatically when I really step on it, the turbo will only boost smooth when I barely engage the spool up....It has just started to do this after installing the ECS N75 H valve. I need to find out what type N75 my AWP engine needs????
 

· Registered
Joined
·
23,062 Posts
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

Do you have the stock N75 valve to stick back in?
Also, did you correctly install the "H" valve?
- Erik
 

· Registered
Joined
·
695 Posts
try the n75j if you want, it's an older peice that sends boost info to the ecu slower meaning your car dosen't adjust it's self as frequently giving you smoother boost (correct me if im wrong)
any y bother changing the n75 if your not chipped?
 

· Registered
Joined
·
88 Posts
Discussion Starter · #7 ·
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (bluefox280)

I do have the stock one to put back in, its just a pain with those one time use clips! I did have it professionally installed, soo Im pretty sure it is done right.
 

· Registered
Joined
·
88 Posts
Discussion Starter · #8 ·
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

I am not chipped and I definatley do like it when I hit the turbo smoothly because It does let it deliver more boost overall, its just when I really step on it....the wastegate on the turbo is flapping like crazy so the turbo is sooo sparatic.......Damn if I do try the J N75 I hope I don't go through all this after buying it!!
 

· Registered
Joined
·
23,062 Posts
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

Quote, originally posted by JettMobberGli »
I do have the stock one to put back in, its just a pain with those one time use clips!

The point during the install was to remove the "one-time" hose clamps and place on standard adjustable worm-screw ones.
Quote, originally posted by JettMobberGli »
I did have it professionally installed, soo Im pretty sure it is done right.

That's ok; but did you verify all connections?
Quote, originally posted by JettMobberGli »
its just when I really step on it....the wastegate on the turbo is flapping like crazy so the turbo is sooo sparatic...

The "surging" you're feeling is more common with the "H" version.
Have you scanned the car with a VAG-COM to see if there are any fault codes?
Have you data-logged the requested vs. actual boost readings?
- Erik
 

· Registered
Joined
·
23,062 Posts
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

Quote, originally posted by JettMobberGli »
So yoo think I should go get the J version of the N75?

Well, no. Not yet at least.
You need to figure out what software you want first.
Different versions of the N75 act better / worse with different programming.
With no "flash" currently, I'd would stay with the stock N75 unit...
- Erik
 

· Registered
Joined
·
13,353 Posts
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

Quote, originally posted by JettMobberGli »
I am thinking Unitronic software for the future over Giac..

I see you're located in Utah. Alot of people swap their oem n75 valves back in during the winter months because of surging. Don't ask me why, I have no clue, just what I've read.
 

· Registered
Joined
·
13,353 Posts
Re: 1.8T Boost Problem: What N75 do I need??? H valve=Turbo proble ... (JettMobberGli)

Quote, originally posted by JettMobberGli »
R u saying that the oem n75 will surge in the cold?

no, "H" and other n75 valves, stock is fine
 

· Registered
Joined
·
16,177 Posts
N75 are hit and miss. You're causing a mechanical malfunction who's side effect is slightly increased boost. Are you surprised it backfires sometimes?
Which N75 to use? the stock one. Other N75s aren't doing anything for you anyway, except maybe sending you into limp mode until you're chipped.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top