VW Vortex - Volkswagen Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I'm looking to buy this 2002 Audi A4 Avant 3.0 Quattro with about 78k miles. When I spoke to the seller, he told me that the engine computer may need replacing and reprogramming due to the cam sensor getting 12v when it should be getting 5v. Here are the codes when plugged in to a OBD2:p0348 - Camshaft Position Sensor (G163) Short to Plus
P0343 - Camshaft Position Sensor (G40) Signal too High
P0393 - Camshaft Position Sensor (G301) Signal too High
P0368 - Camshaft Position Sensor (G300) Signal too High

P0103 - Mass Airflow Sensor (G70) Signal too High
P0136 - Oxygen (Lambda) Sensor B1S2 Malfunction in Circuit
P0135 - Oxygen (Lambda) Sensor B1S1 Heating Circuit Malfunction

The closest Audi dealership to me is 2 hours away and I'm not sure if I'll be able to make the trip considering that the vehicle is having these issues, if I do buy the car. It looks to be in very good condition outside of these codes. What could be the issue and what might be the fix? Thanks to everyone who contributes in advance!
 

·
Registered
Joined
·
32 Posts
I'm looking to buy this 2002 Audi A4 Avant 3.0 Quattro with about 78k miles. When I spoke to the seller, he told me that the engine computer may need replacing and reprogramming due to the cam sensor getting 12v when it should be getting 5v. Here are the codes when plugged in to a OBD2:p0348 - Camshaft Position Sensor (G163) Short to Plus
P0343 - Camshaft Position Sensor (G40) Signal too High
P0393 - Camshaft Position Sensor (G301) Signal too High
P0368 - Camshaft Position Sensor (G300) Signal too High

P0103 - Mass Airflow Sensor (G70) Signal too High
P0136 - Oxygen (Lambda) Sensor B1S2 Malfunction in Circuit
P0135 - Oxygen (Lambda) Sensor B1S1 Heating Circuit Malfunction

The closest Audi dealership to me is 2 hours away and I'm not sure if I'll be able to make the trip considering that the vehicle is having these issues, if I do buy the car. It looks to be in very good condition outside of these codes. What could be the issue and what might be the fix? Thanks to everyone who contributes in advance!
i think the cuze of Os2 sensor codes its an intake air leak ore poor fuel pressure maybe you got shorted wire with cam sensor wires you have to check the wiring
 
1 - 2 of 2 Posts
Top