VW Vortex - Volkswagen Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys,
Pretty new to the forums here. I have a 2019 GTI Rabbit Ed. 13k miles on it. Only thing installed is a neuspeed power module. Installed that back in October and no problems after installation. About a two weeks ago, I noticed the car idling funny on warm start up with an occasional soft stall, almost like the stop start system required a manual start. This week on warm start it revved like I had tapped the gas. Im getting about 260 miles a tank with conservative driving but don't smell fuel anywhere. Took to my work (also a dealer) and service blames the power module. Not really sure whats going on or if anyone has any suggestions. I will be more than happy to answer any questions I might've missed in the post too. Thanks!
 

·
Registered
Joined
·
21,815 Posts
Interestingly enough, I just had something like this happen to my bone-stock 2019 GTI with 5k miles on it. Started the car and the revs just climbed and climbed, ended up sitting just below 2k. No amount of tapping the gas would make them drop and trying to drive off was... awkward. It settled into normal idle after 30 seconds of driving. Taking it in tomorrow for that and some other things (among them are the radio randomly freezing and the squeaks and rattles. SOOO MANY RATTLES AND SQUEAKS! WTF? My Mk6 didn't squeak and rattle like this after 65k miles.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Interestingly enough, I just had something like this happen to my bone-stock 2019 GTI with 5k miles on it. Started the car and the revs just climbed and climbed, ended up sitting just below 2k. No amount of tapping the gas would make them drop and trying to drive off was... awkward. It settled into normal idle after 30 seconds of driving. Taking it in tomorrow for that and some other things (among them are the radio randomly freezing and the squeaks and rattles. SOOO MANY RATTLES AND SQUEAKS! WTF? My Mk6 didn't squeak and rattle like this after 65k miles.
My friend has a 17 and he said there's a lot of rattles. Cheaper materials. Hopefully it'll get better with the MK8. I took the power module off so we'll see if it gets better.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Update: The power module has been removed. The car has stalled on 2 separate occasions. One time, the dealer found a fuel delivery error. It stalled a third time yesterday. This time, it was a warm start and idled for a couple of seconds and then stalled. Smelled gas from the vents when it stalled. Restarted and it popped and crackled like a tuned car and had a rough idle. It wouldn't let me rev more than 1.5k RPMs for about a second or two. No CEL during this whole time. No idea what it could be.
 
1 - 4 of 4 Posts
Top