VW Vortex - Volkswagen Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 08 Q7 is new to me, purchased about a year ago in 2020, and since then, I found a good local Eugene OR Audi/VW specialist for any issues that might stand out that needs done to it over the past year. (I know next to nothing about these vehicles So I need all the advice I can get. )

I brought it in to get a portion of coolant hose replaced because I was told there was a pinhole in it, ran beautifully before I brought it in, and no issues, no check engine light, nothing.

I go to pick it up when they’re done replacing the hose, and they tell me that it now throws a code for an injector 4 and it runs and idles like it’s about to ****ing blow up 🙄 kinda like I’m sitting in a hot rod, just shaking at idle and running really rough. I just need to know if they’re giving me a line of **** or if I need to drop a thousand dollars on Labor and an injector? Could it be a sensor being knocked loose causing it to throw the injector code? 😬
 

·
Registered
Joined
·
715 Posts
more than likely they pulled too hard on the wire harness for the lower 3 injectors and wires came out of the connector. there is a coolant pipe under intake manifold and the lower injector harness clips into this pipe, if this is the pipe they replaced, they may have caused this damage. sounds like they do not want to own up to it. I see this post is from a while back, so i am curious what the outcome is.

I believe you are not responsible for this repair since its related and in the area to the work they performed.
 
1 - 2 of 2 Posts
Top