VW Vortex - Volkswagen Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
Ive got a 90 Jetta GTX with the 2.0L 16v motor running CIS-E Motronic. Runs really rich and its got a pretty rough idle and giving it gas the throttle has slow response and wavers around inconstently no matter what position I hold it at. Obviously making much less power with all the hesistation. Gets a bit worse with the engine warmed up. Harder to start when warm. Engine diesels after ignition is shut off. First starting it idles around 700 then climbs up slowly to around 950 rpm.

Ive got the haynes and bentley manual for my car and have been checking everything I have the tools for as specified by the book.

Things Ive tried:
Replaced vac lines and checked for air leaks; none found
Replaced/repaired damaged wiring going to sensors in engine bay
Cleaned and tested ISV - works
Adjusted air plate sensor position to spec
Replaced entire distributor unit, car now has basically all new ignition components, from coil to dizzy to plugs and wires. Adjusted timing for ignition as specified by bentley, cyl 1 at tdc, lined up the distributor mark with the center of rotor. Checked other timing marks, all were good.
New cts
Idle switch clicks on off for closed and full throttle properly
New fuel injector seals
Replaced broken ignition reference sensor
Checked fuses
Tested csv
Tested carbon canister solenoid valves

Ive pulled the codes from the computer and gotten these inconsitently.
2231, idle speed stabilizer system exceeded range
2112 ignition reference sensor (before replacing)
1111 defective ecu
1231 speed sender
2342 o2 sensor system (got a big crack in my exhaust header not to mention whatever is causing my car to run really rich)
2142 knock sensor 1 (resistances are same for both my sensors and it has continuity to the the ecu connector)

I pulled the connector off the ecu and tested its pins to the specs in the bentley manual. Here I found a couple things;
Idle switch closed the resistance is high at 4.5 ohms
Air flow sensor potentiometer between pin 23 and 26 I found resistance to be double the acceptable value. Got a reading from 7000 ohms and as high as 14000 with no change in test conditions...
Knock sensor 2 I wasnt able to get continuity, was a little confused since I originally got a code for sensor 1 not 2.

Is it possible the potentiometer or the idle switch could be causing these types of issues?
If not my next plan is start checking fuel pressure, and possibly get a timing light and make sure I installed the distributor right although I dont see why its not correct right now.
All input is appreciated, Ive done my fair share of searching up this issue but havent found something thats worked for me yet, anyone?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 · (Edited)
Update:
Got the car to idle smooth but its not driveable at all yet. Found a loose connection on one of the solenoid valves and swapped vacuum lines for throttle body to the correct spot on the brake booster valve, although it was still getting vacuum before. Also changed my o2 sensor after testing it and finding it to be no good.

So the car idles smooth now, when i try give it gas it buckles, hesitates and misfires losing power then climbs rpm suddenly gaining some power and hovers within 100-50 rpm of where I'm holding the throttle. Have got it to rev to almost 4 grand with a decent bit of gas. Letting off the throttle goes back to a smooth idle. Trying to blip the throttle as the rpm is dropping to idle causes a lot of misfire and hesitation and even backfired one time pretty bad.

Last I drove the car I couldnt get past 2000 rpm trying to accelerate in 1st gear, severe loss of power accompanied with hesitation every time i try and give it gas. Felt it would stall out if i tried getting to another gear, not having enough power to push the car at that point.
Got these codes last time it ran:
2231
1231
2342
2142

Going to check timing with a timing light next to make sure thats set up proper even though I set it according to the bentley. Help would be appreciated.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top