VW Vortex - Volkswagen Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
988 Posts
Discussion Starter #1
I have a 95 A6 that runs great, but engine light randomly comes on. It is never on when I start the car, only comes on after 10-30 minutes of highway driving. No codes ever come up in a scan, so I have no way to pull a code. It also seems to be dependent on the temp outside, and type of driving Im doing. My guess is an O2 sensor, but don't know how to see which one. Anyone else ever had a similar issue, or any ideas on how to get this car to spit out a code
New tune up, timing belt, filters, fluids
thanks
 

·
Registered
Joined
·
3,805 Posts
I have a 95 A6 that runs great, but engine light randomly comes on. It is never on when I start the car, only comes on after 10-30 minutes of highway driving. No codes ever come up in a scan, so I have no way to pull a code. It also seems to be dependent on the temp outside, and type of driving Im doing. My guess is an O2 sensor, but don't know how to see which one. Anyone else ever had a similar issue, or any ideas on how to get this car to spit out a code
New tune up, timing belt, filters, fluids
thanks
Get a ScanGauge (or similar) and monitor codes while driving. You can get an ODB-1 adapter off ebat for US$10 or so, and run the gauge for a long drive. It'll store codes.

Sounds like an O2 sensor, and the scan will tell you which side and (pre- or after-cat).

2.8L motor?
 

·
Registered
Joined
·
1,963 Posts
Mine does the same thing, it's the EGR valve (exhaust gas recirculation). It's a $200 part that only helps with emissions, so I continue to ignore it. :)

You can blink the codes out on our cars using a paperclip and jumping wires together in the engine compartment.
 
1 - 3 of 3 Posts
Top