VW Vortex - Volkswagen Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I'm seeing a lot of people talk about having to replace their ribbon, but I was hoping to get some clarification before I get too crazy.

Here's my situation:

When I put a DVD in the dash player, sound comes through and video shows on the dash screen. No video on the 2 VES screens in the back.
When I put a DVD in the VES player, there is no sound at all, but it does sound like it's spinning up and reading.
The middle row screen is always black and the rear screen does have the split screen.

All this came to happen when:
1)Cam sensor needed to be replaced, but I rode around for a while without getting it replaced.
2)Car wouldn't start one morning.
3)Cam sensor got replaced that day.
4)drove it home and put it in the garage.
5) next morning, car won't start.
6)Call AAA, they say the original/7 year old battery is drained down to 30 amps from 600, which probably means something drained it, but it wasn't giving a good reading to know if it needed to be replaced or not. It did jump fine though...
7) just had the battery replaced
8) I realize the screens aren't working.

The clarifications I'm looking for:
1) Should I first check the fuses or do anything special there?
2) Has everyone else been getting sound when they play DVDs in the VES system and only missing video? I wanted to make sure I don't have a unique situation
3) Is there any other thing to check before the kit?



It's been a crappy past few days. File this under "Things I wish I knew before crap hit the fan"
 

·
Registered
Joined
·
16 Posts
In short...I have the same issue you have with the VES. Sort of.

I've been working on my van A LOT the past 5 months. It's been out of commission since September. Original root cause was a broken valve spring I believe. But I had a local mechanic misdiagnose it as electrical "meltdown" and the 'Local' VW place misdiagnose as catalytic converter it as well. Brought it back home to a different local shop and he checked compression. Pulled the valve cover and 'boom'...broken valve spring, dislodged push rod and cracked valve cover inner plastic. Replaced spring and rod and she runs great. BUt now I have a transmission that won't shift. 'Limp' mode-no doubt from all the electrical crap that I had to do.

Well, reverting back to my original diagnosis as electrical, I replaced the wiring harness in the engine area. In doing so I was disconnected from the battery for extended periods. Before all this happened I had the VES issue you have no doubt read about where the ribbon is the problem. It was like that when we bought it. I replaced the ribbons and could only ever get 1 screen to work. Can't remember if it was 2nd row or 3rd row. But it would also play on the main touch screen up from when we had the DVD in the main head unit. I don't recall my actual VES DVD player ever working as it should.

I said all that to say this...apparently these units are extremely finicky when it comes to power-surges, shorts, bad connections, etc. When I get the time I will go back through mine and check it all over again. In you case, if you didn't have issues before I would 1) Check the fuse. 2) Make sure the battery is good and charged. 3) Check the ribbons-they are aggravating to do because so much has to be taken off to get to them, but waaaaay better than buying a whole unit. 4) VW has the ability to diagnose VES issues. Your local Chrysler dealer may also. But it will cost ya.

Sorry I couldn't be more help. Also sorry this forum is kinda dead. Seems like people are abandoning the Routan faster than rats leaving the Titanic. I've found more help visiting the Chrysler Minivan Forums.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
to be completely honest, I was actually hoping replacing the ribbon wouldn't fix the issue. It's just that ludicrous that a silly little cable inside the unit would 1) be so detrimentally affected by replacing the battery and 2) That the symptoms were so illogical, that who would have thought to look at a ribbon? Obviously, I have no idea what that ribbon does, but man, what an Achilles heel!!!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top