VW Vortex - Volkswagen Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,256 Posts
Discussion Starter · #1 ·
This is to all the APR stage 3 turbo kit guys. I had my kit installed this passed week and I have a problem. At WOT my boost peaks at 23ish psi, then drops instantly to 16psi, and then goes to 19 and bounces between 18 &19 psi till redline. I know my boost levels are under what is normal but that's because I have twin intercoolers.
Now to my question. What version or letter N75 valve are you using? I'm going to try to switch out my "C" version for some other ones to see if that helps my irratic boost problem.
 

·
Registered
Joined
·
1,256 Posts
Discussion Starter · #3 ·
Re: APR Stg 3 guys, what N75 are you running? (einsig)

Thanks einsig, that's what I thought too. I also forgot to add that my car did the exact same thing with my GIAC chip, only to a lesser degree.
 

·
Registered
Joined
·
1,256 Posts
Discussion Starter · #5 ·
Re: APR Stg 3 guys, what N75 are you running? (LA Wolfsburg)

No clutch slippage as of yet, but I can tell it's about to start. Good thing I got a new clutch and LSD sitting in my room waiting for the stock ones to go.
 

·
Registered
Joined
·
2,599 Posts
Re: APR Stg 3 guys, what N75 are you running? (stuex)

I have whatever came with the 2000 AWD engines. I am not totally sure what version it is. but now that I read your post...I think my car is doing this too..Under load up top on the freeway. I wonder if mine is shot too?
Could it also be a DV failing to hold boost? I am still running my OEM DV as well.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top