VW Vortex - Volkswagen Forum banner
1 - 18 of 18 Posts

· Registered
Joined
·
1,284 Posts
Discussion Starter · #1 ·
Just got my enigne swapped at the dealership and as soon as I got it back I have this problem.
While I am driving specifically on ramps on highways, accelerating 'spiritedly' to get up to 110km/h or so to merge on the highway, one of two things happens....
When the car switches to 4th, its barely noticible - it's like the car moves into 4th 10km/h to soon...
right after it does this my transmission puts me into 3rd, or most often, 2nd - throwing the RPM waaaay up to 6500/7000 which is a little scary on the highway as I almost got rear ended twice b/c of the resistence in the tranny when my cars shifts down....
So I took it the dealership and they said that there was too much tranny fluid. They drained it enough to make the tranny fluid level perfect.... and the car was perfect for 2 days.... and then on the 3rd day.... SAME THING...
I've done some searching and found it could be a 'speed sensor' b/c i feel that the car is shifting into 4th far too soon...
your thoughts as I will be at the dealership tommorow morning....
it's a 99.5 2.0 btw...
 

· Registered
Joined
·
2,456 Posts
Re: Auto Jetta Tranny Problem (HarrisonBCarter)

its most likey your fluid levels.... vw automagic tranny's are very level sensitve.... it took a few tries to get my buddy's automagic tranny fluid levels right.... almost feels like the transmission has a mind of its own.... good luck http://****************.com/smile/emthup.gif
 

· Registered
Joined
·
1,284 Posts
Discussion Starter · #6 ·
Re: Auto Jetta Tranny Problem (Undubbed)

So I went to the dealerhsip this morning, and with a vag, the deaker and I jumped into the car.
It was obvious it was the fluid levels b/c there were no codes coming up on the vag.
Took the car back in hopisted it up and found that there was a dent in my tranny fluid pan, from awhile back... So it could be very well throwing the fluid levels off, either too high..too low or not right...
So we drained some fluid and took the car back out, the tranny had trouble getting into 3rd as well as 4th.
Took it back in hoisted it up, added a half quart to overfill it
the car had trouble with 3rd, and 4th, as well when it's in drive it's in 2nd rather than 1st.
So I left the car with him and he's gonna swap on a new tranny oil pan to make sure the level is Exactly where it needs to be, because he could be there for days eyeballing with that dent in there.
The reason why my tranny fluid was topped up and waht not after the engine swap was that when the driveshaft was removed, about a quart of tranny fluid came out with it.... but the seal that was cracked was replaced...so the tranny fluid drastically changing levels in 2 days is unlikely... but as we all know the tranny fluid expands with heat so it could throw the levels off as well
I am extremely confident with my mechanic, I just want to have some piece of mind from others that had the same problem, but since then had it resolved.... so I can sigh a relief rahter than forking out the cash for a new tranny just b/c of fluid problems....
Could it be the torque converter b/c the 4th gear doesn't hold at the given torque and then downshifts?
More thoughts for a thorough post
 

· Banned
Joined
·
32,045 Posts
Re: Auto Jetta Tranny Problem (HarrisonBCarter)

the torque converter is not the issue...I would check to make sure that the kick-down selinoid is working correctly..and as you stated the correct amount of fluid in the unit....
no codes in the scan mean nothing....use the VAGCOM to watch (measuring blocks) when the trans shifts...that is controlled by the ECU....and the trans ECU communicating....is it possible that the trans you have now is NOT matching the trans controller in the trans ECU???
 

· Registered
Joined
·
1,284 Posts
Discussion Starter · #8 ·
Re: Auto Jetta Tranny Problem (LSinLV)

is it possible that the trans you have now is NOT matching the trans controller in the trans ECU???

when you get an engine doesn't the ecu stay the same... no ecu got swapped regarding the tranny -- unless the tranny isn't liking the engine?
 

· Banned
Joined
·
32,045 Posts
Re: Auto Jetta Tranny Problem (HarrisonBCarter)

Quote, originally posted by HarrisonBCarter »
is it possible that the trans you have now is NOT matching the trans controller in the trans ECU???

when you get an engine doesn't the ecu stay the same... no ecu got swapped regarding the tranny -- unless the tranny isn't liking the engine?

just like there are about 5 versions of the 1.8T motor, there are several versions of software to run the tranny's, as well as several different Aisin/Warner Tranny's that can be put in a car...all dependant on year/VIN....
Since you mentioned you swapped tranny's I would verify this before anything else....I am not saying that this is definitively your issue, but it would be good to rule it out.
http://****************.com/smile/emthup.gif
 

· Banned
Joined
·
32,045 Posts
Re: Auto Jetta Tranny Problem (HarrisonBCarter)

Quote, originally posted by HarrisonBCarter »
I apologize the tranny is original with the car - the engine just got swapped...

well then, we just ruled out my concern...

I would go back to using the measuring blocks on the tranny...not sure what blocks, but you can watch the shift selenoids, etc....
again, I doubt it's the TC or the front pump....something electrical/mechanical in the shift points....
 

· Registered
Joined
·
1,284 Posts
Discussion Starter · #13 ·
Re: Auto Jetta Tranny Problem (HarrisonBCarter)

fixed, after the tranny fluid pan was straightened out... as it was bent and throwing the levels off....
topped up to a perfect level and taken for a 45 minutes test drive and did driving that would cause the car to mis shift...... nothing
So i'm crossing my fingers b/c after this......
YIKES!!
 

· Registered
Joined
·
1,284 Posts
Discussion Starter · #16 ·
Re: Auto Jetta Tranny Problem (HarrisonBCarter)

So if anyone still cares about this post.....
It's come down to the classic disagreement with the dealership.
I am foreced to get another transmission that would run me 2000 - 2500 for a tranny that never gave me any problems in the past and the dealership ain't on my side as they want me to take resposibility for it.
I drive the car cold and up to the delarship which takes about 30 minutes... everyhting is perfect...driving likea grama with very friendly shifts and what not...
as soon as I say "let's go" and give it a little pep it gives me a little ****....
Sooo I currently talking with VW Canada and am filing a complaint with the dealership....seeing what transcends.. then going to small claims court after shelling out the money at a different dealership
Any advice on options.... Please post as I am in a terrible terrible position
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top