VW Vortex - Volkswagen Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter · #1 ·
2002 1.8t gti , stage 2 and all that, was driving on the highway, when the car lost power, pulled over checked all hoses pipes, everything is in place. drove again, step on it 25%, loses power again, rev it in neutral, turbo doesnt pump, took to the closest mechanic, CEL CODE: ECM malfunction

any suggestions? i have a stage 2 unitronic chip, pushing 24psi...
could it be chip failure?
 

·
Registered
Joined
·
15,635 Posts
FV-QR

ECM and ECU are two different things. IIRC I've heard that a certain ECM is prone to failure. (or I could be making that up)


Edit: ^ I was wrong. I was thing of the CCM. :D
 

·
Registered
Joined
·
15,635 Posts
what about re-chipping it?
and how much do ecm's go for?
Yeah you may have to replace it.

You can get an ECU off ebay for like $100. Then it will have to have the immobilizer defeated. If it was an ECU for your engine code then it should work. If not, then you have to get it tuned. I would get an aftermarket tune since you are pulling the ECU out anyway.

Or you can get your car to the dealer and let them do their magic for a large price.


And to touch on what I posted before... When you said ECM I thought CCM. ECM and ECU are the same thing.:thumbup:
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #9 ·
ECM and ECU are the same thing.:thumbup:
:)

i dont think its the ECU itself tho, because i suppose if they stop working, you cant even start the car, it controls the whole car, what i think it is , just the software (chip) malfunction,so i will get it diagnosed, and take to my unitronic dealer with a proof that its a software malfunction,and they will reinstall it for free, otherwise, im fucccked!!!
 

·
Registered
Joined
·
15,635 Posts
Are you running a KO4 turbo with 24 PSI? That's a lot of boost for the stock Turbo. I've read that anything over 20 on the KO3 is really hard on it.
I peak at 25 on my k03.
 

·
Registered
Joined
·
15,635 Posts
How long have you been running it like that? Mine peaks at 19 but holds at 15. I heard they are pretty durable but can't handle much over 20 for long.
Peak at 25 and hold at 20. Doesn't mean I do that at every light though. Ive had that tune for a year now. Previously I had GIAC and that was like 22 and 18 for two years. Ko3s is holding strong.
 

·
Registered
Joined
·
116 Posts
Discussion Starter · #15 ·
i get a feeling it might be the maf sensor now, car runs in limp mode! havent tried 3rd and 4th gear yet, but first two run in limp mode, and i can step on it all the way, yesterday it would cut the gas off if i did that...
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top