VW Vortex - Volkswagen Forum banner

1 - 20 of 390 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
EPC and Engine light

This is my first VW and I'm still figuring out stuff. I got into the car after work and just pressed start/stop engine button. This started the head unit, interior lighting and hvac system. On the instrument cluster I see EPC and engine light on. These lights go away when I start the engine. But while running on battery those two light are on. Car was in park with hand brake applied. I can replicate it easily. Is this a common behavior? If yes what does those lights mean?
 

·
Registered
Joined
·
26 Posts
Nothing to worry about. Almost all cars display all dash lights when the car is in standby/on battery mode. You should worry when that engine light comes on when the motor is actually running :)
 

·
Registered
Joined
·
53,322 Posts
This is my first VW and I'm still figuring out stuff. I got into the car after work and just pressed start/stop engine button. This started the head unit, interior lighting and hvac system. On the instrument cluster I see EPC and engine light on. These lights go away when I start the engine. But while running on battery those two light are on. Car was in park with hand brake applied. I can replicate it easily. Is this a common behavior? If yes what does those lights mean?
OK, get into any car, turn the key on but don't start the engine. Look at the gauge cluster. What do you see?
 

·
Registered
Joined
·
15 Posts
EPC & Engine Light

Hey all,

I have a new 2015 VW Golf TSI Auto, it only has about 1200kms on it. This morning my girlfriend was driving it to the train station and the "EPC" and engine light both came on, she said it was very sluggish after that. I went to pickup the car and it drove normally without any lights on to the dealer - they told me to just monitor it and if it comes back on then I should schedule an appointment.

Does anyone have any experience or know what might be going on? I am just worried because this car is brand new.

Thanks,
 

·
Registered
Joined
·
3,370 Posts
The light cleared its self?
This happened to me once when I had a misfire (2010 CC though). It was a one time thing in 4 years I owned it.

Without getting the code its impossible for us to help with what could have happened.
Could have been a one time bug, I would not worry about it too much.
If there was an issue it won't be anything big and you are under warranty.

The sluggish car was because it went into limp mode to protect it self, but it just recovered by a restart?
 

·
Registered
Joined
·
15 Posts
Yup, by the time I got the car (hour later), I started it and it cleared itself, running normally. Drove it for about 20 minutes to the dealer and back.
 

·
Registered
Joined
·
15 Posts
We've noticed that on the TSI now, when we turn the key once on the engine - it is showing an EPC + oil light solid, once the key is turned again to start the car - it's gone away and business as normal.

Also on the TDI, one key turn and the oil light is on, and once again turns off once the key is turned to start the car..

Are either of these normal?
 

·
Registered
Joined
·
53,322 Posts
We've noticed that on the TSI now, when we turn the key once on the engine - it is showing an EPC + oil light solid, once the key is turned again to start the car - it's gone away and business as normal.

Also on the TDI, one key turn and the oil light is on, and once again turns off once the key is turned to start the car..

Are either of these normal?
I haven't had a vehicle that was not like that for over 30 years. Where have you been? :screwy:
 

·
Registered
Joined
·
3,370 Posts
We've noticed that on the TSI now, when we turn the key once on the engine - it is showing an EPC + oil light solid, once the key is turned again to start the car - it's gone away and business as normal.

Also on the TDI, one key turn and the oil light is on, and once again turns off once the key is turned to start the car..

Are either of these normal?
Those sound normal.
 

·
Registered
Joined
·
15 Posts
Thanks Milan, just a bit paranoid now.

The dealer was too busy to look at it, just kind of shoo'd me away since nothing was acting up when I dropped by.
 

·
Registered
Joined
·
3,370 Posts
When you take your car in for service tell them to do a scan, which they should be doing anyway.
I don't like that the dealer told you to go away...did you buy from them?
 

·
Registered
Joined
·
15 Posts
Nope. I purchased the car where I used to live in Toronto, but since have moved out to Whitby (1.5hrs from purchase dealer).

As soon as I mention that it was not purchased (Owasco VW in Whitby) from them, you can tell there is a tone change.
 

·
Registered
Joined
·
788 Posts
Nope. I purchased the car where I used to live in Toronto, but since have moved out to Whitby (1.5hrs from purchase dealer).

As soon as I mention that it was not purchased (Owasco VW in Whitby) from them, you can tell there is a tone change.
In what universe is Owasco 1.5 hours from Toronto. I can make it from Kitchener to Owasco in 1:45.

Anyways man, you shoulda got it scanned. But, since so much time has elapsed I am sure you have had it scanned somewhere and are about to post the findings.
 

·
Registered
Joined
·
15 Posts
I don't think I made reference from Owasco to Toronto, I said it was 1.5 hours from my area to the dealer that I purchased it from. Owasco is just the closest VW dealership.

And no, it hasn't been checked. I've been told from Owasco that it's not a big deal and I can schedule an appointment to bring it in, but they are currently backed up until starting next week sometime.
 

·
Registered
Joined
·
1,323 Posts
There should be a stored fault code that the dealership or even VAGCOM can find. It may be a one time occurrence and nothing to worry about as mentioned above. With as many electrical systems we have in these cars, there are bound to be small glitches or errors from time to time. If it happens again or begins to happen frequently, then you should definitely take it to the dealership for diagnosis. If it continues to drive normally and the EPC light stays off, then I would not worry about it.
 

·
Registered
Joined
·
15 Posts
Appointment is scheduled for next week, the EPC light has stayed off entirely since once the car is started. However, when you turn the key once (engine is not running) - the EPC & oil light are solid, once the engine starts - they both go away.

Aside for this, both of the Golf's brakes are extremely squeaky in the morning - the TDI is louder than a siren the first couple of brakes.
 

·
Banned
Joined
·
21,195 Posts
op where you bought the car from should not make a difference what so ever how the car is treated for service. In or out of warranty.
 

·
Registered
Joined
·
53,322 Posts
.....the EPC light has stayed off entirely since once the car is started. However, when you turn the key once (engine is not running) - the EPC & oil light are solid, once the engine starts - they both go away.....
This is exactly how every VW, and every other make, function. With the ignition on but the engine not started, the cluster does a icon function check. Once you start, the test is over.
 

·
Registered
Joined
·
1,323 Posts
Appointment is scheduled for next week, the EPC light has stayed off entirely since once the car is started. However, when you turn the key once (engine is not running) - the EPC & oil light are solid, once the engine starts - they both go away.

Aside for this, both of the Golf's brakes are extremely squeaky in the morning - the TDI is louder than a siren the first couple of brakes.
It is normal for those lights to come on with the key on and engine off. The brakes will be noisy for the first few stops, VW has been having issues with this for the last couple of years. I have customer complaining of this all the time and there really is no fix unless the rotors are glazed. There is a TSB to install updated rear pads for some Jettas and Beetles, but no other vehicles right now.
 
1 - 20 of 390 Posts
Top