VW Vortex - Volkswagen Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

I have a 2013 Tiguan SE. 2.0 TSI

Recently, the water pump failed (due to a failed o-ring and broken plastic housing).
I replaced the water pump with an aftermarket aluminium unit, that seems to be made very nicely.
Replacing the water pump required removing the intake manifold, throttle body, air box, and disconnecting a lot of wiring harnesses.
Pulling the intake manifold also brought 3 of the injectors out with it.

After putting everything back together, I started the car...

- Initially, the engine misfired a number of times. I assume this is because of the empty fuel rail needed to repressurize.
After turning the car off, and back on I didn't get any more misfires.

- Today, I took the car for its first drive and I got a number of codes.

- The EPC light came on close to home, so I drove back home - restarted the car - and the EPC light went away and hasn't come back.

- After that, I drove around the block and noticed a loss of power and P0321. I cleared that code, and thought I'd take another lap around the block to see if it did it again.

- On the second lap, I got a code for P2293 - but P0321 did not come back.

- The car will not rev above 2500 RPMs when driving or in Park or Neutral.

- The check engine light DID NOT come on, and EPC hasn't come back on either, but I do see these codes.

- The engine is also making quite a 'ticking' sound, but looking around online it seems like that is normal for the 2.0 TSI engines.

P0321 = Ignition / Distributor, Engine Speed Input Circuit, Range / Performance

P2293 = Fuel Pressure Regulator 2 Performance


My research shows that it may be a faulty cam-shaft position sensor. Maybe I didn't reconnect it fully.. I will check when the engine cools down.

I assume this is a result of me not reconnecting something properly, but I'm not sure where to start looking other than the cam-shaft position sensor.


Thank you for your help!

- Jack
 

·
Registered
Joined
·
2 Posts
Hi,

I have a 2013 Tiguan SE. 2.0 TSI

Recently, the water pump failed (due to a failed o-ring and broken plastic housing).
I replaced the water pump with an aftermarket aluminium unit, that seems to be made very nicely.
Replacing the water pump required removing the intake manifold, throttle body, air box, and disconnecting a lot of wiring harnesses.
Pulling the intake manifold also brought 3 of the injectors out with it.

After putting everything back together, I started the car...

- Initially, the engine misfired a number of times. I assume this is because of the empty fuel rail needed to repressurize.
After turning the car off, and back on I didn't get any more misfires.

- Today, I took the car for its first drive and I got a number of codes.

- The EPC light came on close to home, so I drove back home - restarted the car - and the EPC light went away and hasn't come back.

- After that, I drove around the block and noticed a loss of power and P0321. I cleared that code, and thought I'd take another lap around the block to see if it did it again.

- On the second lap, I got a code for P2293 - but P0321 did not come back.

- The car will not rev above 2500 RPMs when driving or in Park or Neutral.

- The check engine light DID NOT come on, and EPC hasn't come back on either, but I do see these codes.

- The engine is also making quite a 'ticking' sound, but looking around online it seems like that is normal for the 2.0 TSI engines.

P0321 = Ignition / Distributor, Engine Speed Input Circuit, Range / Performance

P2293 = Fuel Pressure Regulator 2 Performance


My research shows that it may be a faulty cam-shaft position sensor. Maybe I didn't reconnect it fully.. I will check when the engine cools down.

I assume this is a result of me not reconnecting something properly, but I'm not sure where to start looking other than the cam-shaft position sensor.


Thank you for your help!

- Jack
How did you make out here? I am thinking I need the water pump replaced in mine but not sure.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top