VW Vortex - Volkswagen Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,370 Posts
Discussion Starter · #1 ·
Hey guys, I've got a problem.... my rocco bogs down in 2nd and 3rd gear when I turn higher rpms it sounds like it wants to stall.....
I've got spark, so thats not the problem, and I've:
-Changed the fuel pump relay
-Changed the fuel pump
-Installed new fuel lines
-Cleaned out the air flow sensor plate
-Checked the Air/Fuel mixture
Now where would I go???

I don't have an O2 sensor because I have headers... but it never caused a problem b4... any help would be appreciated
Thanks,
Jesse
 

·
Registered
Joined
·
5,508 Posts
Re: Help, my 84 rocco is losing power in 3rd! (Scirocco_Clan_Man)

ok first things first
does your car have a full size spare tire ?

if it does not you have 2 fuel pumps and your intank pump is going to die on you or your screen on the intank pump is plugged i had the same thing happen to me so i changed the out fuel pump no tknowing i had 2 pumps i was young lol

let me know im sure we can get it worked out http://****************.com/smile/emthup.gif
 

·
Registered
Joined
·
2,370 Posts
Discussion Starter · #3 ·
Re: Help, my 84 rocco is losing power in 3rd! (wolf rocco)

the car has the smaller spare... its not a fullsize.. I changed the fuel pump and the other thing that was right beside it... I had no clue what it was other than it had fuel lines coming from it. I had a spare fuel pump off of an 86 that worked great with the other piece, so I just changed them both.
My next guess is its either the lack of an O2 Sensor or the fuel filter may be clogged...
 

·
Registered
Joined
·
5,508 Posts
Re: Help, my 84 rocco is losing power in 3rd! (Scirocco_Clan_Man)

so you have one in your tank then if you got the small spare
that one is easy to change or to clean off the screen on it
 

·
Registered
Joined
·
1,973 Posts
How's the cat looking? Are you running knock sensor? I don't run an 02 sensor on my CIS engine and the car runs fine. What engine are you running?
 

·
Registered
Joined
·
2,370 Posts
Discussion Starter · #6 ·
Re: Help, my 84 rocco is losing power in 3rd! (Scirocco_Clan_Man)

Hey guys, thanks for the trouble shooting... I needed the help.. To conclude this, it was the intank fuel pump, there was no filter on it, so it sucked up all the crap in my tank and clogged the pump... I replaced the pump and got the filter and it runs better than ever. Anyway, since I've got new-found power, I'm gonna go spank some honda's

Thanks guys, you rule!
Jesse
 

·
Registered
Joined
·
5,508 Posts
Re: Help, my 84 rocco is losing power in 3rd! (Scirocco_Clan_Man)

glad to here she is back and working how long did it take to swap and to check
 
1 - 8 of 8 Posts
Top