VW Vortex - Volkswagen Forum banner
1 - 11 of 11 Posts

· Registered
Joined
·
775 Posts
Discussion Starter · #1 ·
I was just driving my car alittle hard. Im at about 5000 rpms and i here a pretty loud cracking sound. I recently installed a FMIC and i made all the pipes but i havnt welded them yet. Im using couplers for now. I was thinking maybe one of the pipes blew off or somthing. But if so, its not obvious from just looking at it. I havnt jacked it up yet or anything. My car will start and idle normal then go down to like 4-500 rpms and almost die. Do you think it could be my turbo. Would my car run if it was my turbo. I had my wife come pick me up cause i didnt want my car to die in traffic or mess it up worse. Just thought maybe you guys could give me ideas on what you think it could be. Or if you think it would be alright to drive home???
Thanks for any help
oh yeah and im using GIAC software and just basic bolt on mods.
 

· Registered
Joined
·
7,852 Posts
Re: (GT-ER)

when mine blew off it did that but didnt sound like a crack, sounded more like you blowing into a paper bag/ziploc then poping it against your hand going boom, def was loud and scared the bejesus out of me, i know it had to scare the guy in the 'vert stang next to me (top down)
 

· Registered
Joined
·
8,643 Posts
Re: (theswoleguy)

Quote, originally posted by theswoleguy »
when mine blew off it did that but didnt sound like a crack, sounded more like you blowing into a paper bag/ziploc then poping it against your hand going boom, def was loud and scared the bejesus out of me, i know it had to scare the guy in the 'vert stang next to me (top down)

LOL...it happened to me too...I thought I blew the engine.
 

· Registered
Joined
·
7,852 Posts
Re: (GT-ER)

Quote, originally posted by GT-ER »
LOL...it happened to me too...I thought I blew the engine.

yes as you feel your heart sink deep down in your stomach and the words "o sh*t" come to mind, then you dont see oil under the car or under the hood and see the pipe/coupler blown apart
 

· Registered
Joined
·
775 Posts
Discussion Starter · #8 ·
haha well now i know the feeling you guys are describing. I went back to my car and unplugged the MAF sensor and it idles fine. So i drove it home like that. The way home i could here my turbo spool so i know its fine. Even though my boost guage didnt detect any boost. Now i no what my car would feel like without a turbo. I got some new intercooler piping im gonna weld up and use that. so that i have less of a chance for boost leaks and pipes blowing off like this again. thanks for the help
 

· Registered
Joined
·
7,852 Posts
did the turbo spool sound alot louder? if so then yea you def blew a pipe off, but dont keep trying to boost, that can create an overboost type of scenario on the turbo and you can over spool it still w/o pressure against it
 

· Registered
Joined
·
8,643 Posts
Re: (theswoleguy)

Quote, originally posted by theswoleguy »
did the turbo spool sound alot louder? if so then yea you def blew a pipe off, but dont keep trying to boost, that can create an overboost type of scenario on the turbo and you can over spool it still w/o pressure against it

That, and also make the turbo blow oil like crazy into the intake side. http://****************.com/smile/emthup.gif
 

· Registered
Joined
·
11,615 Posts
Re: (GT-ER)

Quote, originally posted by GT-ER »

That, and also make the turbo blow oil like crazy into the intake side. http://****************.com/smile/emthup.gif
From the lack of no back pressure?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top