VW Vortex - Volkswagen Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 09 Jetta 2.5 and when I was driving the other day my speedometer and gas gauge went all crazy then immediately my epc light came on along with my power steering light and my check engine light. I already had my abs light on for over a year but it never gave me any issues with braking so I let it be. I've been on here researching what it could be but it looks like it could be multiple things wrong but what are the chances they all go bad at exactly the same time. Could this be my computer located under the dash behind my wipers causing all these different issues at once or is it my speedo sensor or my abs module?
 

·
Registered
Joined
·
278 Posts
When my Rabbit passed 142K miles, I started getting a lot of unexplained lights which did not include a CEL, but did include a battery light. These were intermittent and sometimes my cruise control would not turn on unless I turned off the engine and tried again. After a lot of troubleshooting, I figured I may as well change the alternator which was the original one, since it was probably at the end of its life. After I replaced it, all was good and none of the problems ever returned.

I paid a little more to buy a remanufactured one from NAPA with a lifetime warranty and I'm very happy with it. It is a DIY job but not very easy. There are several YouTube videos on this and you can access it by dropping the AC compressor without disconnecting it.
 

·
Registered
Joined
·
5,979 Posts
No speedo and gas gauge going crazy is typical failed vehicle speed sensor symptoms. Can't help you specific to your car but start your search at VSS for yours. Some have a sensor in the trans connected to the output shaft and some uses wheel speed sensors which might be related to your abs light being on too.

For positive ID find an independent VW/euro shop with VCDS or similar, or a local with VCDS or OBD11 and do a full vehicle scan. Report back with whatever codes, specifically from the engine and brake modules.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Wouldn't a test show if the alternator was bad? I mean I'm sure you ran a full diagnostic on yours but doing so didn't show that the alternator was malfunctioning? I ask because I had my car diagnosed and my voltage was good according to the diagnostic.
 

·
Registered
Joined
·
278 Posts
Wouldn't a test show if the alternator was bad? I mean I'm sure you ran a full diagnostic on yours but doing so didn't show that the alternator was malfunctioning? I ask because I had my car diagnosed and my voltage was good according to the diagnostic.
I had no CEL...just a battery light showing when I started the engine from warm and at low idle. When I started the cold engine, the higher revs apparently prevented the battery light. Anyway, I've had the new alternator in for over 10K miles and none of the previous warning lights have returned.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top