VW Vortex - Volkswagen Forum banner
1 - 4 of 4 Posts

25 Posts
Discussion Starter · #1 ·
I changed my upper control arms in my Q7, since then, the vehicle has been stuck in Automatic mode. Couldn't find much on this other than one thread about an Allroad where the user helping the OP said that if any suspension components are disconnected, recalibration is in order to regain the manually controlled functions (dynamic/comfort/offroad).

So this is the process that I've found on OBDeleven forums, on Ross-Tech, and many other threads, even YouTube videos showing the process where everyone else seems to be having success other than me on recalibrating the air suspension.

The steps from many sources;
Connect OBDeleven Dongle and open the app

Scan for codes if any, do not clear codes (just a precautionary step)

Open the Control Units, and open module 34 (Level Control in VCDS, Ride Control System in OBDeleven), you can see I don't have any codes for module 34.

Tap on Security Access and enter the access code 31564

Tap on Adaptation (module 10 in VCDS)

Enter channel 1

Wait until the "wait" message goes away (compressor will turn on as it begins to drain and reinflate to what it thinks is it's correct default ride height)

This is where my issues begin.

After it completes it's run of draining the bags and reinflating, I get the error "(22) Function Canceled, Marginal Conditions Have Not Been Met"

At this point if I go back, and tap on Adaptation again, I have to reenter the channel 1 I'm attempting to go to, where it will ask for a security login, I enter the same 31564 as before, only to get the same error saying "(22) Function Canceled, Marginal Conditions Have Not Been Met"

I have to turn the vehicle off and back on to regain any function in OBDeleven (can't even scan for codes).

I've thought maybe this was an Android 10 bug as it's still fairly new, so I tried my old Nexus 6P running Android 7 with the identical results, I also tried rolling back the APK file to the one before the update from a couple days ago with no avail.

This also happens whether the vehicle is just "ON" or Running, same results, however if the vehicle is running, I also get a code for lane assist not working, and for the brake pad wear sensors (brakes are brand new, just did new OEM pads, aftermarket drilled and slotted rotors, and OEM sensor about 1000km ago and didn't have a code).

I cant get passed this step, not entirely sure what to do at this point, the vehicle is stuck in the garage, and we just got over a foot of snow and continuing over night, so I kind of need the additional height of putting this in Offroad mode, even Comfort mode would help (it's stuck on the second cube which is normally Dynamic height even though every option is greyed out except for Automatic)

Any help is appreciated.

Sent from my SM-G975W using Tapatalk
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.