VW Vortex - Volkswagen Forum banner
  • Mwerks and Fourtitude have rejoined VWVortex. For more info, see this thread.

1 - 4 of 4 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
The rear wiper blade on my 2012 Routan is not making good contact with the glass. It turns on and acts like it's wiping, but doesn't actually clear the glass. I have tried four or five different brands/styles of wiper blade and none of them make any difference. It's like there is no wiper blade at all. If I push the blade down towards the glass with my hand while it is wiping, it makes stronger contact and clears the glass.

Any ideas on what the fix is? Is the spring in the wiper arm supposed to be pushing the blade towards the glass? It doesn't seem to offer much resistance when I pull up on the arm. Maybe I need to replace it?
 

·
Registered
Joined
·
46 Posts
The rear wiper blade on my 2012 Routan is not making good contact with the glass. It turns on and acts like it's wiping, but doesn't actually clear the glass. I have tried four or five different brands/styles of wiper blade and none of them make any difference. It's like there is no wiper blade at all. If I push the blade down towards the glass with my hand while it is wiping, it makes stronger contact and clears the glass.

Any ideas on what the fix is? Is the spring in the wiper arm supposed to be pushing the blade towards the glass? It doesn't seem to offer much resistance when I pull up on the arm. Maybe I need to replace it?
Chances are the hinge is binding due to corrosion, you can try spraying oil into the hinge and working it back and forth to loosen it up.
 

·
Registered
Joined
·
1 Posts
Same problem I had. After using wd40 still the same. I took the wiper arm off and bent it at the curve towards the glass. Works like a charm now.
 
1 - 4 of 4 Posts
Top