VW Vortex - Volkswagen Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
2,362 Posts
Discussion Starter · #1 ·

My schrick is not working correctly. I need some help.
what it should do. start car led turns green, 4000rpm turns red , controller sends signal to vacume cyliniod and valve opens, 3950 coming down valve closeslight turns back to green.

what is happening.
start car.. light turns green. when the t.b. adapts and kicks down the light flashes from green to off. actuating the vacume cylinoid opening and closing in about 1 second intervals. Tach inside care is going up and down slightly at the same intervals.
what could cause this to happen? bad tach signal maybe? any help would be great.
 

·
Registered
Joined
·
37,711 Posts
Re: schrick intake... flash dance of lights.... help needed. (USOPHUNKE)

So the tach signal doesn't actually actuate the controller, it just gives rpm reference. The controller itself checks the tach signal vs the dip switch settings and then there is another circuit that does the actual activation.
I don't use the flapper assembly on mine so I'm not much more help. You can use something like an RPM window switch (with pills) if the Schrick box doesn't work.
 

·
Registered
Joined
·
2,362 Posts
Discussion Starter · #9 ·
last night double checked vacume and it was correct. moved power to the switched power off the coil and redid the tach connection. it got slightly better.
now it will stay green till the first time you hit 4000 rpm, then the valve opens.
after that it starts its open close crap again. and tach starts its up down crap.
going to try another ground, if that doesnt work I will be buying a window switch.
 

·
Registered
Joined
·
2,362 Posts
Discussion Starter · #14 ·
fixed... it was a multiple of wiring issues. bad connections and a bad ground.
I cant believe how quick my little coupe gets to 110 now. fun fun

oh for anyone searching.
obd2
red wire goes to black wire on coil pin plug. It is the one on the end closest to the back of car.
black wire goes to ground... I ended up running right to my main battery ground as It just seemed better.
blue wire goes into ecu wiring harness to green and black... you need to really sodder this one in too. those little wire cut adapter plugs dont seem to work to great for it.
everything is under my rain tray heat shrunk and covered. came out ok in the end.


Modified by USOPHUNKE at 9:02 AM 7-11-2009
 

·
Registered
Joined
·
95 Posts
Re: (USOPHUNKE)

another option you have for controlling one of these is this

http://www.summitracing.com/pa...large
my schrick didn't come with anything so i went this way instead of the factory controller. You can also change what rpm things happen very easy with this thing.
Also as far as the RPM signal, on my OBD1 coilpack setup i was able to add a wire into plug A2 (can't remember exactly where right now but i know it was one of the A's) and just use that. Doing it this way i didn't need to alter any of the factory wires because i just added a new one. I'll get the exact plug and pin next time I'm near the car.
With this setup i have the control box inside so if i want to do a run with the manifold open the whole time i just set the open RPM to 1K or something.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top