VW Vortex - Volkswagen Forum banner
1 - 3 of 3 Posts

Registered
Joined
24 Posts
Discussion Starter · #1 ·
So, my W8 is having a weird issue with the engine temp. As it sits and idles it's fine. But if I drive it on the highway the temp goes up just above the 190 and sits there. Doesn't change really how hard I drive it, and the heater had no effect on the temp. So does this sound like a failed thermostat to anyone else? The coolant is full, and it's recently changed last summer.
 

Registered
Joined
7 Posts
i delt with a stuck open thermostat during the cold Nebraska winter 馃ザ Are you engine cooling fans running higher than normal? check engine lights? You may have a stuck closed thermostat or a poor performing one to where its not opening all the way? It is a MAP controlled thermostat (ECM input/output) by 2 coolant temp sensors, 1 at the top radiator hose and another behind and underneath the throttle body. i would check to see if these are acting up first. the front sensor may not be reading correctly and the ECM is only picking up the engine outlet temp? this is a cheaper/easier fix. But if it ends up being the thermostat, it may seem like a big task but once you get started, its fairly easily. Its below the intake plenum and runner. If you do change the thermostat and go with the cheaper aftermarket one, you will need to cut the OE harness plug that goes to the thermostat and splice in some extra wire to reach the new thermostat's plug. If you have basic mekenick skills and tools, you should be just fine. id give this a 4 out of 10 on difficulty. just dont drop anything down into the intake runners of the heads 馃構 good luck
 
1 - 3 of 3 Posts
Top