VW Vortex - Volkswagen Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
536 Posts
Was there a battery in these clusters that kept memory and basic running of the screen?

Where in Canada are you?
Be great to meet another G60.
I'm in BC
 
  • Like
Reactions: YONI RED

·
Registered
Joined
·
90 Posts
Typically there was just a very large capacitor to keep the clock alive during brief power outages. The start battery was responsible to keep the electronics alive during engine off. A lithium coin cell or it's analog would be too unreliable in an automotive application, plus it would be a maintenance item. Check fuses first, maybe one supplies the LCD panel and associated electronics.
 

·
Registered
Joined
·
3,473 Posts
T28/17 is B+ to the clock (MFA). The Bentley says it’s 11, but that one of many errors in it. As long as the battery’s connected and has power the clock should show. The repair procedure for your issue is to disconnect the battery and reconnect. If it doesn’t come back then replace printed circuit board.

I would check for power at T28/17 first. You can disconnect the connector and use a test light grounded to the bus under the dash. It should light up when you touch 17 without the key because it’s circuit 30. If it does your board is dead.
 

·
Registered
Orig owner 90 g60, 02 allroad 6SP M w/ 3rd Row, 07 3X White NB Vert, 09 Escalade ESV Plat to tow em
Joined
·
8,334 Posts
It’s not uncommon to simply reseat or wiggle the harness connectors against their input pins.

Working from the hole where the left side hvac vent is, you can reach all the way behind the cluster with the louvers pulled and some of it’s surrounding trim removed.

It’s not a fun job to remove the cluster and reinstalling the speedo cable isn’t fun.

Often it’s easier to source another cluster because you’ll need spare parts down the road. If the spare fixes things, it’s really easy to work backwards and verify if it’s internal or a connection issue.

When I got into my cluster it opened the door to install new gauge faces and led bulbs while still having a working cluster.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
628 Posts
Discussion Starter · #6 ·
Was there a battery in these clusters that kept memory and basic running of the screen?

Where in Canada are you?
Be great to meet another G60.
I'm in BC
Yes, there a battery in fact the screen is iluminated but the numbers doesn´t appear.
I´m from México but I have the cluster from European version
And this is my bad boy
Wheel Tire Vehicle Car Hood
 

·
Registered
Joined
·
628 Posts
Discussion Starter · #7 ·
T28/17 is B+ to the clock (MFA). The Bentley says it’s 11, but that one of many errors in it. As long as the battery’s connected and has power the clock should show. The repair procedure for your issue is to disconnect the battery and reconnect. If it doesn’t come back then replace printed circuit board.

I would check for power at T28/17 first. You can disconnect the connector and use a test light grounded to the bus under the dash. It should light up when you touch 17 without the key because it’s circuit 30. If it does your board is dead.
The lcd is iluminated but the information doesn´t appear
 

·
Registered
Orig owner 90 g60, 02 allroad 6SP M w/ 3rd Row, 07 3X White NB Vert, 09 Escalade ESV Plat to tow em
Joined
·
8,334 Posts
Ah, I was going to include this clip but knew US g60 clusters were unlikely to fail like described.



Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
536 Posts
Ah, I was going to include this clip but knew US g60 clusters were unlikely to fail like described.



Sent from my iPhone using Tapatalk Pro
Another of Mr S. Harper's many great tutorials.
Good cat!
 
  • Like
Reactions: YONI RED
1 - 13 of 13 Posts
Top