VW Vortex - Volkswagen Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
329 Posts
Discussion Starter · #1 ·
My turn signals recently stopped working....For a while they didnt work very well if you just switched the lever up or down, but if I pulled lightly backwards on them (as if to turn the high beams on but not pull back all the way) the signals would start to work...Now that trick doesnt work any longer. I just replaced the signal stalk out of a parts car that I know the turn signals work on...put it in my car and they still dont work. All the bulbs work...The emergency lights flash. When I hit the signal, the dash light stays a solid non-blinking green and no exterior signals turn on. When the stalk is in the 'neutral' position, the dash turn signal light is still on, but a very faint dim green. Any quick help would be appreciated. This is starting to piss me off
 

· Registered
Joined
·
300 Posts
Re: Turn Signal Help - Need help ASAP (ShastyMcJasty)

im having this same issue. i tried to replace the fuse to no avail, next on the list is the relay. after that i dont know what to try. any ideas or first hand knowledge on correcting this would be appreciated. and yes i did just bring this back from the dead. http://****************.com/smile/emthup.gif
 

· Registered
Joined
·
2,224 Posts
Re: Turn Signal Help - Need help ASAP (ShastyMcJasty)

Have you cleaned the contacts? I'd guess not.
Just remove the signal lever and take it apart. The copper contacts can easily be cleaned with either contact cleaner (make sure to wipe off any run-off so that it doesn't eat the plastic), or a pencil eraser.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top