VW Vortex - Volkswagen Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2,334 Posts
Discussion Starter · #1 ·
I installed my new Samco boost kit today, and I found a few things that concerned me. First, my stupid coil packs area ll popped up. I have autolites 3922 right now, and will be changing the plugs tomorrow to NGK BKR7E's @ 22ft lbs. and .028 gap. I hope this fixes my coil issues.


After removing the DV, to replace my boost lines, I noticed some oil Asian on this valve thing (what is this valve?) Do I need to worry? I know it may not look like much, but its pretty gooey.
Heres a pic:

Another problem. After removing the top IC to manifold boost line, I noticed quite a bit of oily fluid in the tube, and the top of the IC. In this pic, you can see the brownish color in the tube. it was hard to get a shot, but the whole inside was covered in this thin brown film:

Here is the best pic I could take of the IC outlet:

I was surprised that the throttle body was so clean however
:


Please let me know what I should look into, or repair, or ignore. Thank you all!


Modified by 3wheelinWolf at 5:11 PM 2-13-2004
 

·
Banned
Joined
·
4,542 Posts
I think the Oil is normal accumulation from the PVC/Crankcase etc.
Now concerning the TB;
Even though the TB "Looks" very clean, looks CAN be deceiving! I was having stalling problems, then I looked in my TB, and it "looked" as clean/cleaner as yours.
I cleaned it anyways, and to my relief, the stalling problem went-away!


Modified by exS4 at 10:19 PM 2-13-2004
 

·
Registered
Joined
·
2,334 Posts
Discussion Starter · #3 ·
Re: (exS4)

Quote, originally posted by exS4 »
I think the Oil is normal accumulation from the PVC/Crankcase etc.
Modified by exS4 at 10:19 PM 2-13-2004

Oh, so is that vlave the PCV? I read that I may need to put a check valve in to keep from boost leaking back into the manifold. I have been having boost issues too. Only boosting to 15 psi. Is that the right valve?
 
1 - 3 of 3 Posts
Top